Carpe - Time Recording

Major incident Business Applications
2025-03-04 17:13 GMT · 18 hours, 47 minutes

Updates

Update

This issue is now resolved.

March 7, 2025 · 09:05 GMT
Issue

Multiple reports of Carpe time recording not being accessible.
Finance team is investigating.

March 4, 2025 · 17:13 GMT

← Back